CRMEB商城系统安装环境要求和教程

浏览:113 发布日期:2022/10/13 分类:技术分享
运行环境
CRMEB v4支持Lunix/windows服务器环境,需要PHP7.1 ~ 7.4 版本支持, 可运行于包括Apache和nginx在内的多种WEB服务器和模式,支持Mysql数据库,引擎用InnoDB。框架本身没有什么特别模块要求,具体的应用系统运行环境要求视开发所涉及的模块。 CRMEB底层运行的内存消耗极低,而本身的文件大小也是轻量级的,因此不会出现 空间和内存占用的瓶颈。

注意

+域名必须备案
+公众号必须使用80端口
+小程序必须使用https协议 443端口
+不支持二级目录安装

这里所说的安装其实就是把CRMEB系统放入WEB运行环境(前提是你的WEB运行环境已经OK),可以通过下面几种方式获取和安装CRMEB。

服务器环境推荐要求
* Nignx
* PHP 7.1 ~ 7.4 (标准版v4.4及以后版本兼容7.4,之前版本仅支持到7.3)
* MySQL 5.7
* Redis
* Supervisor管理器
推荐使用bt宝塔面板,简单易用。
服务器推荐阿里云ecs或腾讯云cvm 云服务器。
开放端口
添加8个端口:80,21,8888,888,443,3306,6379,20002/20100
授权对象:0.0.0.0/0
PHP扩展
安装插件 fileinfo、redis
禁用函数
删除下列函数
proc_open pcntl_signal pcntl_signal_dispatch pcntl_fork pcntl_wait pcntl_alarm

执行命令
开启消息队列:
Supervisor管理器,运行

php think queue:listen --queue
开启长连接:

sudo -u www php think workerman start --d
开启定时任务:

php think timer start --d

官网:https://www.crmeb.com
最佳答案
评论( 相关
后面还有条评论,点击查看>>