如果你composer update topthink/framework不能升级到6.0.9或以上

浏览:552 发布日期:2022/01/06 分类:ThinkPHP6专区
升级不报错,只是不更新TP版本
这种情况多半是你更换了php版本,而忘记安装TP6所需的php扩展。
请检查thinkphp6.0.9所需的php扩展是否安装。
需要注意的是除了php默认安装的扩展之外,还有一个扩展是fileinfo

在更换php版本后多次升级thinkphp6无效后,经检查,发现自TP6.0.9开始将"league/flysystem"库的版本更换为 "^1.1.4",而"league/flysystem"要求ext-fileinfo。因此,要升级到TP6.0.9就需要升级league/flysystem,而因为没有fileinfo,所以league/flysystem升级失败,TP也就无法升级。

最佳答案
评论( 相关
后面还有条评论,点击查看>>