致命错误: Class 'think\Queue' not found

浏览:153 发布日期:2019/09/27 分类:求助交流 关键字: TP5.1 queue composer
安装:composer install thinkphp-queue
报错:Invalid argument thinkphp-queue. Use "composer require thinkphp-queue" instead t
o add packages to your composer.json.
再次安装:composer require topthink/think-queue

再次报错:Using version ^3.0 for topthink/think-queue
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- topthink/think-queue v3.0.3 requires topthink/framework ^6.0.0 -> satisfia
ble by topthink/framework[6.0.x-dev, v6.0.0-rc2, v6.0.0-rc3, v6.0.0-rc4] but the
se conflict with your requirements or minimum-stability.
- topthink/think-queue v3.0.2 requires topthink/framework ^6.0.0 -> satisfia
ble by topthink/framework[6.0.x-dev, v6.0.0-rc2, v6.0.0-rc3, v6.0.0-rc4] but the
se conflict with your requirements or minimum-stability.
- topthink/think-queue v3.0.1 requires topthink/framework ^6.0.0 -> satisfia
ble by topthink/framework[6.0.x-dev, v6.0.0-rc2, v6.0.0-rc3, v6.0.0-rc4] but the
se conflict with your requirements or minimum-stability.
- topthink/think-queue v3.0.0 requires topthink/framework ^6.0.0 -> satisfia
ble by topthink/framework[6.0.x-dev, v6.0.0-rc2, v6.0.0-rc3, v6.0.0-rc4] but the
se conflict with your requirements or minimum-stability.
- Installation request for topthink/think-queue ^3.0 -> satisfiable by topth
ink/think-queue[v3.0.0, v3.0.1, v3.0.2, v3.0.3].


Installation failed, reverting ./composer.json to its original content.


很无力的求助~~
最佳答案
评论( 相关
后面还有条评论,点击查看>>