安装thinkphp5+swoole

浏览:447 发布日期:2019/06/12 分类:ThinkPHP5专区 关键字: Swoole安装,tp5+swoole
我根据ThinkPHP5.1 Swoole上手指南去安装的,但是出现了以下的报错,谁能帮我解决一下问题呢?是不是有什么版本的影响啊?

[root@VM_16_13_centos html]# composer create-project topthink/think tp
Installing topthink/think (v5.1.37)
- Installing topthink/think (v5.1.37): Downloading (100%)
Created project in tp
Loading composer repositories with package information
Updating dependencies (including require-dev)
clea^HPackage operations: 2 installs, 0 updates, 0 removals
- Installing topthink/think-installer (v2.0.0): Downloading (100%)
- Installing topthink/framework (v5.1.37.1): Downloading (100%)
Writing lock file
Generating autoload files
[root@VM_16_13_centos html]# cd tp/
[root@VM_16_13_centos tp]# composer require topthink/think-swoole
Using version ^3.0 for topthink/think-swoole
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Your requirements could not be resolved to an installable set of packages.

Problem 1
- topthink/think-swoole v3.0.2 requires topthink/framework ^6.0.0 -> satisfiable by topthink/framework[6.0.x-dev, v6.0.0-rc2, v6.0.0-rc3] but these conflict with your requirements or minimum-stability.
- topthink/think-swoole v3.0.1 requires topthink/framework ^6.0.0 -> satisfiable by topthink/framework[6.0.x-dev, v6.0.0-rc2, v6.0.0-rc3] but these conflict with your requirements or minimum-stability.
- topthink/think-swoole v3.0.0 requires topthink/framework ^6.0.0 -> satisfiable by topthink/framework[6.0.x-dev, v6.0.0-rc2, v6.0.0-rc3] but these conflict with your requirements or minimum-stability.
- Installation request for topthink/think-swoole ^3.0 -> satisfiable by topthink/think-swoole[v3.0.0, v3.0.1, v3.0.2].


Installation failed, reverting ./composer.json to its original content.
最佳答案
评论( 相关
后面还有条评论,点击查看>>