ThinkPHP5.1.0RC1核心版

浏览:1255 最后更新:2017-09-13 13:52 分类:框架
ThinkPHP5.1在5.0的基础上对底层架构做了进一步的改进,引入新特性,并提升版本要求。ThinkPHP5.1运行环境要求PHP5.6+,虽然不支持5.0的无缝升级,但升级过程并不复杂(请参考升级指导)

主要新特性:

引入容器和Facade支持
依赖注入完善和支持更多场景
重构的(对象化)路由
配置和路由目录独立
取消系统常量
助手函数增强
类库别名机制
模型和数据库增强
验证类增强
模板引擎改进
支持PSR-3日志规范

目前5.1版本尚处于RC阶段,仅供学习参考,请勿用于商业项目!

完全开发手册:https://www.kancloud.cn/manual/thinkphp5_1/353946
评论( 相关
后面还有条评论,点击查看>>